Page 1 of 1

Validating problem

Posted: Fri Apr 30, 2010 11:33 am
by smile100h
Hi, I just tried to use the demo/developer account for my production web application. The tool "VoiceXML Validator" doesn't like my working URL and doesn't provide any detailed error log. How can I proceed from this point? Thanks.

Re: Validating problem

Posted: Fri Apr 30, 2010 3:28 pm
by support
Hi,

Could you send us a small snippet of the IVR code that you are trying to validate with the VoiceXML Validator? This would help us better in troubleshooting your issue.

Regards,
Plum Support

Re: Validating problem

Posted: Fri Apr 30, 2010 3:51 pm
by support
Also, please keep in mind that the URL that you are trying to validate with the VoiceXML Validator must return valid VXML (for example, if you open up a page such as http://www.example.com/somesample.htm in a web browser and hit Ctrl+U with your keyboard to view the source code, if the code was in between <html> and </html> tags (indicating this is HTML code), then that would be invalid VoiceXML being returned back).

This page may further help in troubleshooting your issue: http://www.plumvoice.com/docs/dev/plumdevguide:debugging

Regards,
Plum Support

Re: Validating problem

Posted: Fri Apr 30, 2010 4:27 pm
by smile100h
Thanks for your suggestion. I may figure out what's wrong. My program will detect which client platform is based on incoming user-Agent parameters. When it cannot recognize it, it will return default html page. I may need to fix my program first.