IVR SOAP not resolving

Questions and answers about Plum iOn systems

Moderators: admin, support

  • Author
  • Message
Offline

pguser1

  • Posts: 3
  • Joined: Wed Jun 15, 2011 11:57 am

IVR SOAP not resolving

PostWed Jun 15, 2011 12:04 pm

Hi Scott,
I’m not sure why I we cant figure out the soap response question type on our survey(TEST IVR copy1). I have read all the documentation and still can’t get it to reject a response.
I have two answers(11111,22222) to question_texts(ENTER 5), which refers to question number 1 on PAGE1-TEST of survey=TEST IVR copy1.

SURVEY
http://survey.plumvoice.com/admin/surve ... ey_id=3397

WEBSERVICE
http://ec2-50-17-199-131.compute-1.amaz ... .asmx?wsdl
Offline

support

  • Posts: 3529
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Re: IVR SOAP not resolving

PostWed Jun 15, 2011 1:09 pm

Hi pguser1,

Thanks for your inquiry.

Before answering your web service question, please note that we have a SOAP validation tool to help you debug web service issues. For a link to this SOAP web service tester, please see here.

We've looked into your survey and web service and have found that your web service returns neither "accepted" nor "rejected" for your digits question, "ENTER 5", with input of "11111".

Using the SOAP web service tester, here is what gets returned in the SOAP Response Envelope:

Code: Select all
<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<soap:Body>
<plumEvalResponse xmlns="http://tempuri.org/">
<plumEvalResult>
<NewDataSet xmlns="">
<Table>
<answers>11111
</answers>
</Table>
</NewDataSet>
</plumEvalResult>
</plumEvalResponse>
</soap:Body>
</soap:Envelope>


For our sample webservice, here is what gets returned in the SOAP Response Envelope for a yes/no question of "Did you find this survey helpful?" and input of "no":

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://survey.plumvoice.com" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<SOAP-ENV:Body>
<ns1:plumEvalResponse>
<return xsi:type="xsd:string">rejected
</return>
</ns1:plumEvalResponse>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>


Within our sample web service code, we had set up the following for our "plumEval" function:

Code: Select all
  function plumEval($question_texts, $answers) {
    foreach ($answers as $answer) {
      if ($answer == 'yes') {
        if ($_SESSION['accepted-once']=='yes') {
          return 'accepted again';
        }
        $_SESSION['accepted-once']='yes';
        return 'accepted';
      }
    }
    return 'rejected';
  }


As a suggestion, within your web service code, you could set up your function to return "accepted" if the answer returns a specific 5 digits such as "11111" and to return "rejected" for any other input.

Hope this helps.

Regards,
Plum Support
Offline

pguser1

  • Posts: 3
  • Joined: Wed Jun 15, 2011 11:57 am

Re: IVR SOAP not resolving

PostWed Jun 15, 2011 2:39 pm

Done for now.
Last edited by pguser1 on Wed Jun 15, 2011 4:10 pm, edited 1 time in total.
Offline

support

  • Posts: 3529
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Re: IVR SOAP not resolving

PostWed Jun 15, 2011 3:42 pm

Hi pguser1,

We've looked at your issue again, and have noted the following within the SOAP web service tester for your web service, http://ec2-50-17-199-131.compute-1.amaz ... .asmx?wsdl, with "question_texts" of "ENTER 5" and "answers" of "33333":

Code: Select all
<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<soap:Body>
<plumEvalResponse xmlns="http://tempuri.org/">
<plumEvalResult>
<NewDataSet xmlns="">
<Table>
<response1>rejected
</response1>
</Table>
</NewDataSet>
</plumEvalResult>
</plumEvalResponse>
</soap:Body>
</soap:Envelope>


Is there any specific reason why the namespaces, NewDataSet, Table, and response1, are included? Also, please note that the web service question requires a string to be returned to it (as noted above in our sample web service).

Regards,
Plum Support
Offline

pguser1

  • Posts: 3
  • Joined: Wed Jun 15, 2011 11:57 am

Re: IVR SOAP not resolving

PostWed Jun 15, 2011 4:11 pm

Done for now.

Return to Plum iOn Q&A

Who is online

Users browsing this forum: No registered users and 1 guest

cron