SOAP request

Questions and answers about Plum Fuse+

Moderators: admin, support

  • Author
  • Message
Offline

thomas.carroll

  • Posts: 9
  • Joined: Tue May 09, 2017 11:14 am

SOAP request

PostFri Jul 28, 2017 2:01 pm

Team i am attempting to utilize the SOAP tool within the call flow. I am testing the call using your SOAP tester that PlumVoice offers. the call is set up in the flow under Stellar ACH IVR.
Offline

shelly.barnett

  • Posts: 3
  • Joined: Thu Oct 24, 2019 6:16 pm

Re: SOAP request

PostThu Oct 24, 2019 6:56 pm

I am having issues calling a soap server that is currently used with another vendor. The request does not work with the Plum soap tester, but we have run through another tester and request works fine. We find that when we apply the request to the Soap Test or in call flow data is not returned and our request seems not to populate correctly.

Using the soap tester we get the following with the following request

WSDL
https://ivr.paystationdeploy.com/IVRDat ... singlewsdl

Parameter


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="https://ivr.paystation.com">
<SOAP-ENV:Body>
<ns1:FirstRequest>
<ns1:IVRProfileId>3</ns1:IVRProfileId>
<ns1:CustomerPhone>2061234567</ns1:CustomerPhone>
<ns1:SecurityResponse>0000</ns1:SecurityResponse>
</ns1:FirstRequest>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Raw Request

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="https://ivr.paystation.com">
<SOAP-ENV:Body>
<ns1:FirstRequest/>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

Using a different tool

https://wsdlbrowser.com/soapclient?wsdl ... rstRequest

Same Request returns correct response.

We are attempting to not change our current service and use same requests as is. Are we doing something wrong or is there a bug.
Offline

support

  • Posts: 3628
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Re: SOAP request

PostFri Oct 25, 2019 5:52 pm

Hey Shelly,

We are reviewing your post now and are working on an answer with a Dev now, we will update you shortly.

Regards,
Plum Support
Offline

support

  • Posts: 3628
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Re: SOAP request

PostTue Nov 05, 2019 1:23 pm

After some investigation, we have determined the root of the issue you're experiencing when calling SOAP web services is that your service is hosted via ASP.NET. By itself, hosting on ASP.NET is not an issue, as we have many other clients who are using ASP.NET without issue. However, our system does handle web service requests differently when they are hosted on ASP.NET. This decision was made many years ago in order to enable integration with ASP.NET hosted SOAP services and accommodate ASP.NET's behavior at the time.
As a workaround to this issue, we would suggest wrapping the SOAP service with a REST web service. The simplest implementation would be a single endpoint that accepts two parameters: method name and a JSON string of parameters. These values would be passed on to the SOAP service and the results would be returned to the IVR.
This would be a platform-independent solution, self-hosted, and implemented in a language of your choice.

Return to Plum Fuse+ Q&A

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron