Rest API Post call errors

Questions and answers about Plum Fuse+

Moderators: admin, support

  • Author
  • Message
Offline

ccnamlam

  • Posts: 1
  • Joined: Fri Nov 30, 2018 11:00 am

Rest API Post call errors

PostTue Jul 09, 2019 2:22 pm

Hello all,

I am having some trouble with a Rest Post call in my application. I have a server which is setup to receive these Post calls and have tested it with the POSTman application. In addition, I have had the Fuse+ servers whitelisted for communication with our server and have requested that our IP be whitelisted by the Fuse+ servers as well. Despite this, when I use the domain name given to my server in a Post request from my Fuse+ program, the program simply tells me that "an error has occurred. GoodBye". Firstly, is there a better way to get error messages/logs out of this box? Secondly, to test the Fuse end of things, I use the public Rest server at https://postman-echo.com/post. Interestingly enough, when I post to this domain name, my Fuse+ program doesn't error out. Of course, I still don't really have any information either on this public server or my Fuse+ program's post request so it doesn't tell me much. Does anyone know how to diagnose an error like this?

Thank you for your time.
-James
Offline

support

  • Posts: 3627
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Re: Rest API Post call errors

PostFri Jul 12, 2019 10:46 am

Hi ccnamlam,

It looks like after looking at the log (https://fuse.plumvoice.com/logs/call_lo ... 1562604955) we see that you got a 403 with your own URL. We recommend checking that server request because you're likely missing something.

With regards to the error message you hear, "an error has occurred, goodbye." this is because this is the default error message. If you would like to set up a more customized error message you may do so on the REST module in Fuse+.

We hope this helps!
Regards,
Plum Support

Return to Plum Fuse+ Q&A

Who is online

Users browsing this forum: No registered users and 1 guest

cron