Why do my prompts sometimes stop playing in the middle?

Answers to common Plum DEV questions

Moderators: admin, support

  • Author
  • Message
Offline

support

  • Posts: 3628
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Why do my prompts sometimes stop playing in the middle?

PostFri Jun 06, 2003 11:39 am

There is one reason audio prompts will stop playing: user input. VoiceXML scripts that utilize speech recognition are susceptible to "speech bargein" (barge-in). In the code segment below (and across the platform in general), speech bargein is enabled by default. If the user says something or there is excessive noise or dtmf input on the line, the system will stop playing the prompt audio.
Code: Select all
<field name="name" type="digits">
   <prompt>
      <audio src="longaudiofile.wav"/>
      Say your ID number.
   </prompt>
   <filled>
      I heard, <value expr="name"/>.
   </filled>
</field>

There are two ways to prevent noise on the line from triggering this bargein from within your VoiceXML. First, speech recognition can be removed from the list of active input types. This is done using the inputmodes property at the top of your script. Note: in this case, dtmf input will still stop the audio from playing.
Code: Select all
<property name="inputmodes" value="dtmf"/>

Now, only dtmf input can interrupt a prompt.

Second, the bargein attribute can be set to false on the particular <prompt> being interrupted. Once the audio is complete, the system will start looking for user input. Note: this will prevent all forms of input from stopping the audio.
Code: Select all
<field name="name" type="digits">
   <prompt bargein="false">
      <audio src="longaudiofile.wav"/>
      Say your ID number.
   </prompt>
   <filled>
      I heard, <value expr="name"/>.
   </filled>
</field>

If speech recognition with speech bargein is a requirement and the system still seems too sensitive to noise on the line, you can try to use the property name "sensitivity". For example:
Code: Select all
 <property name="sensitivity" value="0.3"/>

By setting the sensitivity to a low value, there will be less sensitivity to background noise. Finally, if the system still seems too sensitive, contact your system administrator about adjusting the bargein decibels setting on the Plum Voice Portal.

Return to Plum DEV FAQs

Who is online

Users browsing this forum: No registered users and 1 guest

cron