Why am I getting error messages about tags/elements that I k

Answers to common Plum DEV questions

Moderators: admin, support

  • Author
  • Message
Offline

support

  • Posts: 3628
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Why am I getting error messages about tags/elements that I k

PostFri Jun 06, 2003 11:41 am

There is more than likely an error (syntactical, runtime, or otherwise) in the scripting code used to generate your VoiceXML (PHP, ASP, Perl, etc.). Typically, messages for such errors are rendered in HTML by the scripting language's interpreter... and then plopped directly into your VoiceXML script.

A typical entry from the error logs might resemble the following:

Code: Select all
Tue 10 Jun 2003 12:58:23 PM EDT (000000;001;1055264269) [inet] EVENT: Attempting to fetch http://your.domain.com/someurl.vxml
Tue 10 Jun 2003 12:58:23 PM EDT (000000;001;1055264269) [vxi] ERROR: DocumentParser::FetchDocument - Parse error in file "http://your.domain.com/someurl.vxml", line 1, column 4 - Unknown element 'br'
Tue 10 Jun 2003 12:58:23 PM EDT (000000;001;1055264269) [vxi] ERROR: errno: 205 uri http://your.domain.com/someurl.vxml
Tue 10 Jun 2003 12:58:23 PM EDT (000000;001;1055264269) [vxi] EVENT: received event: error.badfetch


"But there's no 'br' element in my script!" you say. Try directly visiting the URL in question with your browser to see what it looks like (you may have to select "View : Source" or something similar depending on your browser and/or browser version). Here's what I get in my browser when I visit the above URL (a PHP script):

Code: Select all
<br />
<b>Parse error</b>:  parse error, unexpected T_STRING in <b>/home/tfaiano/public_html/clientsrc/pullapart/lib/test.php</b> on line <b>5</b><br />


When I go back to my source file, I find (regrettably) that there was a syntax error in my PHP code ($elem NULL; rather than $elem = NULL;).

It is also possible that the scripting language error only occurs for certain runtime input, in which case the above aproach may not help. You'll have to be a bit more artful in your debugging.

If you aren't using a scripting language to generate your VoiceXML code, then you probably do have an invalid tag somewhere in your script. Look closely!

Return to Plum DEV FAQs

Who is online

Users browsing this forum: No registered users and 1 guest

cron