Does my VoiceXML document need to have a DOCTYPE declaration

Answers to common Plum DEV questions

Moderators: admin, support

  • Author
  • Message
Offline

support

  • Posts: 3627
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Does my VoiceXML document need to have a DOCTYPE declaration

PostFri Jun 13, 2003 1:54 pm

All VoiceXML documents run under the Plum VP are validated using the appropriate DTD for the platform version; if your document contains some other DOCTYPE declaration, that DOCTYPE declaration is ignored and your document is validated against the platform DTD.

If you which to utilize the document validation features of your third-party markup editor (XMLSpy, Stylus Studio, etc.), you should include the following DOCTYPE declaration in your document:

<!DOCTYPE vxml PUBLIC "-//The Plum Group//Voice Markup Language 2.0//EN" "http://vxml.plumgroup.com/vxml-***.dtd">

where "***" represents the platform version number (e.g. version 2.40 --> 240). This version number is available within the Plum VP Configuration UI.

Return to Plum DEV FAQs

Who is online

Users browsing this forum: No registered users and 1 guest