soaptester - how to submit parameters

Questions and answers about Plum iOn systems

Moderators: admin, support

  • Author
  • Message
Offline

jrf7243

  • Posts: 3
  • Joined: Tue Jan 10, 2012 11:52 am

soaptester - how to submit parameters

PostTue Jan 10, 2012 11:56 am

I would greatly appreciate an example as to how to enter in parameters in the box, parameters when testing my soap methods?
Offline

jrf7243

  • Posts: 3
  • Joined: Tue Jan 10, 2012 11:52 am

Re: soaptester - how to submit parameters

PostTue Jan 10, 2012 1:23 pm

Just to save some time while I am waiting for a response the SOAP Request Envelope generated when a call my Logon method:

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<SOAP-ENV:Body>
<parameters>
<xsd:string>value1
</xsd:string>
<xsd:string>value2
</xsd:string>
</parameters>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

My method has two string type parameters and works from the ASP.Net test page. So when I run the test page I get what I intended:

<?xml version="1.0" encoding="utf-8" ?>
<string>value1</string>

The first parameters is return, however the SOAP Response envelope from you site I get:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<soap:Body>
<LogonResponse />
</soap:Body>
</soap:Envelope>

So this in my opinion is not working as the LogonResponse has no value :?
Offline

support

  • Posts: 3544
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Re: soaptester - how to submit parameters

PostTue Jan 10, 2012 5:23 pm

Hi,

Would you be able to send us a PM containing your web service WSDL as well as some test data we could utilize?

Regards,
Plum Support

Return to Plum iOn Q&A

Who is online

Users browsing this forum: No registered users and 1 guest

cron