Outbound call - starting prompts

Questions and answers about IVR programming for Plum DEV

Moderators: admin, support

  • Author
  • Message
Offline

jason.smoker

  • Posts: 15
  • Joined: Wed Apr 26, 2017 9:41 am

Outbound call - starting prompts

PostWed Jun 21, 2017 10:30 am

I'd like confirmation on what happens between the time an outbound call is initiated and the first VXML form loads. Are the steps below correct?

1. Outbound call requested via queuecall.php

2. If call connects, Plumvoice server waits for input from the end user (i.e. user says "hello") to determine information about the call (i.e. callee type).

3. Once initial call information is retrieved, Plumvoice server makes a request to start_url to get the VXML.

4. VXML and first form loaded.

We would like to have the VXML and prompts start without the initial input. Is this possible? Are there other ways to get to step 3 without the voice input ("hello")? I thought I saw somewhere that DTMF input would work and I've tested it but haven't been able to start the prompts.

Thank you.
Offline

support

  • Posts: 3505
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Re: Outbound call - starting prompts

PostWed Jun 21, 2017 12:48 pm

Hi Jason,

Yes, the steps are correct. The only way to skip the wait time would be to disable callee voice detection, which you can request through support.

Regards,
Plum Support
Offline

jason.smoker

  • Posts: 15
  • Joined: Wed Apr 26, 2017 9:41 am

Re: Outbound call - starting prompts

PostMon Jul 10, 2017 1:13 pm

I was told by Troy Signorelli that it is not possible to eliminate the wait time. Please confirm. It appears the callee voice detection is already disabled on our test account and the prompts are still requiring a "hello" or noise of some kind. This would confirm what Troy is saying.

Thanks,
Jason
Offline

jason.smoker

  • Posts: 15
  • Joined: Wed Apr 26, 2017 9:41 am

Re: Outbound call - starting prompts

PostMon Jul 10, 2017 2:12 pm

Something changed on our account and the prompts are starting without a "hello" or other noise. This is working as we'd like it to.

Jason

Return to Plum DEV Q&A

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron