Why can't I save audio collected with <record>?

Answers to common Plum DEV questions

Moderators: admin, support

  • Author
  • Message
Offline

support

  • Posts: 3628
  • Joined: Mon Jun 02, 2003 3:47 pm
  • Location: Boston, MA

Why can't I save audio collected with <record>?

PostMon Jun 02, 2003 7:39 pm

If you are using <record> to collect audio data, check the following:

1. RECORD: Verify that the audio is being recorded correctly. Before posting to your application server, you can preview the recorded audio by using the <value> tag in a prompt. e.g.
Code: Select all
<record name="name" beep="true">
   <prompt>
      Say your name at the tone
   </prompt>
   <filled>
      I heard, <value expr="name"/>.
   </filled>
</record>


If your recording is getting cut off or clipped, check that the maxtime attribute of the record tag is set high enough. Also, ask your system administrator to check the silence threshold setting of the Plum Voice Platform. Depending on the audio characteristics of your telephone connection, you may need to lower this threshold.

2. POST: If you are posting audio data to your application server to be saved, your application server must accept:
    method="post"
    encoding="multipart/formdata"
Regardless of the <submit> attributes specified in the VoiceXML, the Plum Voice Platform will use these settings to post audio data.

3. AUDIO FORMAT: The audio data is always recorded as:
    format: headerless binary data
    channels: mono
    sample rate: 8 kHz
    encoding: 8 bit u-law (mu-law) or 8 bit a-law coding, depending on the configuration settings for your PlumVP platform installation. Plum Voice Hosting uses the default setting, 8 bit u-law encoding.

In a <submit> audio data is posted as MIME type "audio/basic".

For more information, see <record> in the Programmer's Reference Guide.

Return to Plum DEV FAQs

Who is online

Users browsing this forum: No registered users and 1 guest

cron